Behat

Run Behat tests on Ubuntu 16.10

Submitted by Peter Majmesku on Wed, 10/19/2016 - 15:35

To make it work you need Selenium standalone in version 2.52 and Firefox in version 45. This combination does work. The others do not. Download Selenium standalone in version 2.52 from 

http://selenium-release.storage.googleapis.com/index.html?path=2.52/

Then modify your

/etc/apt/sources.list

to use the packages from Ubuntu 16.04 Xenial. This is described at http://packages.ubuntu.com/xenial/arm64/firefox/download. Afterwards update your package manager, check for the proper package version and install it:

sudo apt update

sudo apt-cache show firefox | grep Version

sudo apt-get install firefox=45.0.2+build1-0ubuntu1

Afterwards you are able to execute your Behat tests. F.e. by this command:

bin/behat --suite=my-test-suite

Subscribe to Behat